Documentation/Tools/SCS Workshop Uploader/versions.sii

From SCS Modding Wiki
Jump to: navigation, search

In the Steam Workshop mods you need to have unit file "versions.sii" containing definitions which content folder should be used for which game version.

This file contains set of package_version_info serialized unit informations with proper set of the attributes.

  • Example file:
 1 SiiNunit
 2 {
 3 package_version_info : .latest {
 4 	package_name: "latest"
 5 }
 6 
 7 package_version_info : .122.content {
 8 	package_name: "content_122"
 9 	compatible_versions[]: "1.22.*"
10 }
11 
12 package_version_info : .120and121.content {
13 	// No special difference between 1.20 and 1.21
14 	package_name: "content_120_121"
15 	compatible_versions[]: "1.20.*"
16 	compatible_versions[]: "1.21.*"
17 }
18 }